Slow performance
Incident Report for Clubhouse
Resolved
We have identified the problem and performance has returned to normal. Continuing to monitor.
Posted over 1 year ago. Feb 21, 2017 - 12:20 EST
Investigating
Our performance on the API server is currently degraded. We are investigating.
Posted over 1 year ago. Feb 21, 2017 - 11:39 EST